题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=6335

Problem Description

m students, including Kazari, will take an exam tomorrow.
The paper consists of exactly n problems, the i-th problem contains ai correct answers and bi incorrect answers, i.e. the i-th problem contains ai+bi candidates in total.
Each student should choose exactly one candidate as answer for each problem. If the answer to a certain problem is correct, then the student will get one point. The student who gets the most points wins.
Students only know the structure of the paper, but they are able to talk with each other during the exam. They decide to choose a subset S of all n problems, and they will only be able to submit answers on these problems.
They want to know the maximum size of S that the winner among them will solve all the problems in S if they take the optimal strategy.


For sample 1, students can choose S={1},and we need at least 4 students to guarantee the winner solve the only problem.

For sample 2, students can choose S={1,2,3}, and we need at least 24 students to guarantee the winner solve these three problems, but if |S|=4, we need at least 96 students, which is more than 50.

Input

The first line of the input contains an integer T (1≤T≤100) denoting the number of test cases.
Each test case starts with two integers n,m (1≤n≤100,1≤m≤109), denoting the number of problems and the number of students. Each of next n lines contains two integers ai,bi (1≤bi≤100,ai=1), indicating the number of correct answers and the number of incorrect answers of the i-th problem.

Output

For each test case, print an integer denoting the maximum size of S.

 

Sample Input

2

3 5

1 3

1 3

1 3

5 50

1 1

1 3

1 2

1 3

1 5

Sample Output

1

3

题目大意:有n道题,m个人,给出每道题对的选项个数和错的选项个数,要求能做对题数最多的那个人做对了几道。

AC代码:

#include<iostream>
#include<algorithm>
#include<stdio.h>
using namespace std;
struct node
{
    int a,b;
    int c;
}a[110];
bool cmp(node x,node y)
{
    return x.c < y.c;
}
int main()
{
    int t;
    scanf("%d",&t);
    while (t--)
    {
        int n,m;
        scanf("%d %d",&n,&m);
        int ans = 0;
        for (int i = 0; i < n; i++)
        {
            scanf("%d %d",&a[i].a,&a[i].b);
            a[i].c = a[i].b+1;
        }
        sort(a,a+n,cmp);
        for (int i = 0; i < n; i++)
        {
            if(m > a[i].b)
            {
                ans++;
                m /= a[i].c;
            }
            else break;
        }
        printf("%d\n",ans);
    }
    return 0;
}