<center style="color&#58;rgba&#40;0&#44;0&#44;0&#44;&#46;87&#41;&#59;font&#45;family&#58;Lato&#44; &#39;Helvetica Neue&#39;&#44; Arial&#44; Helvetica&#44; sans&#45;serif&#59;font&#45;size&#58;14px&#59;">

问题 : Decimal integer conversion

时间限制: 1 Sec   内存限制: 128 MB
</center>

题目描述

XiaoMing likes mathematics, and he is just learning how to convert numbers between differentbases , but he keeps making errors since he is only 6 years old. Whenever XiaoMing converts anumber to a new base and writes down the result, he always writes one of the digits wrong. For example , if he converts the number 14 into binary (i.e., base 2), the correct result should be "1110", but he might instead write down "0110" or "1111". XiaoMing never accidentally adds or deletes digits, so he might write down a number with a leading digit of " 0" if this is the digit she gets wrong. Given XiaoMing 's output when converting a number N into base 2 and base 3, please determine the correct original value of N (in base 10). (N<=10^10) You can assume N is at most 1 billion, and that there is a unique solution for N.

输入

The first line of the input contains one integers T, which is the nember of test cases (1<=T<=8) Each test case specifies:
* Line 1: The base-2 representation of N , with one digit written incorrectly.
* Line 2: The base-3 representation of N , with one digit written incorrectly.

输出

For each test case generate a single line containing a single integer ,  the correct value of N

样例输入

1
1010
212

样例输出

14

解题思路

水题,直接暴力,把所有的情况都跑一遍就可以了。

#include <stdio.h>
#include <string.h>
int main()
{
	int t, A, B, lena, lenb, temp;
	char a[1010], b[1010];
	scanf("%d%*c", &t);
	while (t--)
	{
		temp = 0;
		scanf("%s%s", a, b);
		lena = strlen(a);
		lenb = strlen(b);
		for (int i = 0; i < lena; i++)
		{
			A = 0;
			a[i] = (a[i] - '0' + 1) % 2 + '0';
			for (int j = 0; j < lena; j++)
				A = A * 2 + a[j] - '0';
			a[i] = (a[i] - '0' + 1) % 2 + '0';
			for (int j = 0; j < lenb; j++)
			{
				B = 0;
				b[j] = (b[j] - '0' + 1) % 3 + '0';
				for (int k = 0; k < lenb; k++)
					B = B * 3 + b[k] - '0';
				if (A == B)
				{
					temp = 1;
					break;
				}
				B = 0;
				b[j] = (b[j] - '0' + 2) % 3 + '0';
				b[j] = (b[j] - '0' + 2) % 3 + '0';
				for (int k = 0; k < lenb; k++)
					B = B * 3 + b[k] - '0';
				if (A == B)
				{
					temp = 1;
					break;
				}
				b[j] = (b[j] - '0' + 1) % 3 + '0';
			}
			if (temp)
				break;
		}
		printf("%d\n", A);
	}
	return 0;
}