Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30055    Accepted Submission(s): 18186

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
		
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0

Sample Output
		
45 59 6 13

代码:
#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <set>
#include <queue>
#include <stack>
#include <map>
#include <string.h>
#include <iostream>
#include <vector>
#include <functional>
using namespace std;
int h,w;
char a[25][25];
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
int ex,ey;
int ans;
struct node
{
int x,y;
};
bool check(int x,int y)
{
if(x<h&&x>=0&&y>=0&&y<w) return 1;
else return 0;
}
void bfs(int x,int y)
{
queue<node> q;
node start,next;
start.x=x;
start.y=y;
q.push(start);
while(!q.empty())
{
start=q.front();
q.pop();
for(int i=0;i<4;i++)
{
next.x=start.x+dir[i][
0];
next.y=start.y+dir[i][
1];
if(check(next.x,next.y)&&a[next.x][next.y]=='.')
{
ans++;
a[next.x][next.y]=
'#';
q.push(next);
}
}
}
}
int main()
{
while(~scanf("%d%d",&w,&h))
{
getchar();
if(w==0&&h==0) break;
for(int i=0;i<h;i++)
{
for(int j=0;j<w;j++)
{
scanf("%c",&a[i][j]);
if(a[i][j]=='@')
{
ex=i;
ey=j;
}
}
getchar();
}
ans=
1;
bfs(ex,ey);
printf("%d\n",ans);
}
return 0;
}