在一个给定形状的棋盘(形状可能是不规则的)上面摆放棋子,棋子没有区别。要求摆放时任意的两个棋子不能放在棋盘中的同一行或者同一列,请编程求解对于给定形状和大小的棋盘,摆放k个棋子的所有可行的摆放方案C。

Input

输入含有多组测试数据。
每组数据的第一行是两个正整数,n k,用一个空格隔开,表示了将在一个n*n的矩阵内描述棋盘,以及摆放棋子的数目。 n <= 8 , k <= n
当为-1 -1时表示输入结束。
随后的n行描述了棋盘的形状:每行有n个字符,其中 # 表示棋盘区域, . 表示空白区域(数据保证不出现多余的空白行或者空白列)。

Output

对于每一组数据,给出一行输出,输出摆放的方案数目C (数据保证C<2^31)。

Sample Input

2 1
#.
.#
4 4
...#
..#.
.#..
#...
-1 -1

Sample Output

2
1

 最近整理了一下简单搜索

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <map>
#include <cmath>
using namespace std;
typedef long long ll;
const int N=1e5+30;
int n,m,cnt,ans;
char mp[20][20];
bool vis[20];

void dfs(int tmp)///行数
{
    if(cnt==m)
    {
        ans++;
        return ;
    }
    if(tmp>n)
        return ;
    for(int i=1;i<=n;i++)///列数
    {
        if(mp[tmp][i]=='#'&&!vis[i])///该列还没有元素&&此行此列可以放
        {
            vis[i]=1;
            cnt++;
            dfs(tmp+1);
            vis[i]=0;
            cnt--;
        }
    }
    dfs(tmp+1);
}
int main()
{
    while(~scanf("%d%d",&n,&m)&&n!=-1&&m!=-1)
    {
        getchar();
        memset(mp,0,sizeof(mp));
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
                scanf("%c",&mp[i][j]);
            getchar();
        }
        ans=0;
        cnt=0;
        dfs(1);
        cout<<ans<<'\n';
    }
    return 0;
}