题干:

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

. every student in the committee represents a different course (a student can represent a course if he/she visits that course) 

. each course has a representative in the committee 

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format: 

P N 
Count1 Student1 1 Student1 2 ... Student1 Count1 
Count2 Student2 1 Student2 2 ... Student2 Count2 
...... 
CountP StudentP 1 StudentP 2 ... StudentP CountP 

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 

There are no blank lines between consecutive sets of data. Input data are correct. 

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line. 

An example of program input and output:

Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Output

YES
NO 

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO 

题目大意:

题目大意:

一共有N个学生跟P门课程,一个学生可以任意选一 门或多门课,问是否达成: 

  1.每个学生选的都是不同的课(即不能有两个学生选同一门课)

  2.每门课都有一个代表(即P门课都被成功选过)

输入为:

第一行一个T代表T组数据

P N(P课程数, N学生数)

接着P行:

第几行代表第几门课程,首先是一个数字k代表对这门课程感兴趣的同学的个数,接下来是k个对这门课程感兴趣同学的编号。

输出为:

若能满足上面两个要求这输出”YES”,否则为”NO”

注意:是课程匹配的学生,学生没课上没事.....

解题报告:

   二分图模板,连建图都不需要,,,不解释了

AC代码:

#include<bits/stdc++.h>
using namespace std;
int maze[305][305],nxt[305];
bool used[305];
int p,n,m;
bool find(int x) {
	for(int i = 1; i<=n; i++) {
		if(maze[x][i] && used[i] == 0) {
			used[i] = 1;
			if(nxt[i] == 0 || find(nxt[i])) {
				nxt[i] = x;
				return 1;
			}
		}
	}
	return 0 ;
}

int main()
{
	int t,tmp;
	cin>>t;
	while(t--) {
		memset(maze,0,sizeof maze);
		memset(nxt,0,sizeof nxt);
		scanf("%d%d",&p,&n);
		for(int i = 1; i<=p; i++) {
			scanf("%d",&m);
			while(m--) {
				scanf("%d",&tmp);
				maze[i][tmp] = 1;
			}
		}
		int ans = 0;
		for(int i = 1; i<=p; i++) {
			memset(used,0,sizeof used);
			if(find(i)) ans++;
		}
		if(ans == p) puts("YES");
		else puts("NO");
	}	
	return 0;
}