Bound Found

Time Limit: 5000MS Memory Limit: 65536K Special Judge

Description

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: “But I want to use feet, not meters!”). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We’ll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t.

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

思路:

首先先求出前缀和,然后再用尺取法,在求出前缀和的同时还要记录每个元素的原来的位置,因为要进行排序,然后就会每两个之间的差值的绝对值需要比较的绝对值了,假如大于题目的值的时候,就将左端点++,这样就可以缩小他们之间的差距了,小于的时候的则相反。

#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
const int inf = 0x7fffffff;
struct NODE {
	int sum;
	int id;
	bool friend operator < (NODE a, NODE b) {
		return a.sum < b.sum;
	} 
}; 
NODE node[100010];
int main() {
	int n, k;
	while (scanf("%d %d", &n, &k) != EOF && n && k) {
		int sum = 0, m;
		for (int i = 1; i <= n; i++) {
			scanf("%d", &m);
			sum += m;
			node[i].sum = sum;
			node[i].id = i;
		}
		node[0].sum = 0;
		node[0].id = 0;
		sort(node, node + n + 1);
		while (k--) {
			int x;
			scanf("%d", &x);
			int l = 0, r = 1, minn = inf, ansl, ansr, ans;
			while (r <= n && minn > 0) {
				int dis = node[r].sum - node[l].sum;
				if (abs(dis - x) < minn) {
					minn = abs(dis - x);
					ansr = node[r].id;
					ansl = node[l].id;
					ans = dis;
				}
				if (dis > x) l++;
				else if (dis < x) r++;
				if (l == r) r++;
			}
			if (ansl > ansr) swap(ansr, ansl);
			cout << ans << " " << ansl + 1 << " " << ansr << endl;
		}
	}
	return 0;
}