Reorder the Books

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1315    Accepted Submission(s): 706


Problem Description
dxy has a collection of a series of books called "The Stories of SDOI",There are n(n19) books in this series.Every book has a number from 1 to n.

dxy puts these books in a book stack with the order of their numbers increasing from top to bottom. dxy takes great care of these books and no one is allowed to touch them.

One day Evensgn visited dxy's home, because dxy was dating with his girlfriend, dxy let Evensgn stay at home himself. Evensgn was curious about this series of books.So he took a look at them. He found out there was a story about "Little E&Little Q". While losing himself in the story,he disrupted the order of the books.

Knowing that dxy would be back soon,Evensgn needed to get the books ordered again.But because the books were too heavy.The only thing Evensgn could do was to take out a book from the book stack and and put it at the stack top.

Give you the order of the disordered books.Could you calculate the minimum steps Evensgn would use to reorder the books? If you could solve the problem for him,he will give you a signed book "The Stories of SDOI 9: The Story of Little E" as a gift.
 

Input
There are several testcases.

There is an positive integer T(T30) in the first line standing for the number of testcases.

For each testcase, there is an positive integer n in the first line standing for the number of books in this series.

Followed n positive integers separated by space standing for the order of the disordered books,the ith integer stands for the ith book's number(from top to bottom).


Hint:
For the first testcase:Moving in the order of book3,book2,book1 , (4,1,2,3)(3,4,1,2)(2,3,4,1)(1,2,3,4),and this is the best way to reorder the books.
For the second testcase:It's already ordered so there is no operation needed.
 

Output
For each testcase,output one line for an integer standing for the minimum steps Evensgn would use to reorder the books.
 

Sample Input
2 4 4 1 2 3 5 1 2 3 4 5
 

Sample Output
3 0
 

Source



思路:
题意就是说,给你一个串,每次都可以从第一位后面选一个数放到最后边,问你有多少次,可以使这个序列成为有序数列(实际上是递增序列!我还以为只要是递增或递减的都可以呢...结果到头来原来只是递增的...)。而且数字都是从1开始到n。。大体的思想就是从后往前找,看这个位置k上的数是否是第k大的数,然后如果这个数是第k大的数,那么这个数的位置就不用动,也就是执行操作的时候就少了一步,然后一直这样找下去,那些第k个位置不是第k大的数的数的个数就是要执行的操作数。

代码:
#include<stdio.h>  
#include<string.h>  
#include<iostream>  
#include<algorithm>  
#define MAXN 201000  
using namespace std;  
int a[MAXN];  
int main()  
{  
    int t,i,j,n,num;  
    scanf("%d",&t);  
    while(t--)  
    {  
        scanf("%d",&n);  
        for(i=0;i<n;i++)  
        scanf("%d",&a[i]);  
        int num=n;  
        for(int k=n-1;k>=0;)  
        {  
            if(a[k]==num)  
            num--;  
            k--;  
        }  
        printf("%d\n",num);  
    }  
    return 0;  
}