JGShining’s kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they’re unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don’t wanna build a road with other poor ones, and rich ones also can’t abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities … And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.

In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. _
Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
Output
For each test case, output the result in the form of sample.
You should tell JGShining what’s the maximal number of road(s) can be built.
Sample Input
2
1 2
2 1
3
1 2
2 3
3 1
Sample Output
Case 1:
My king, at most 1 road can be built.

Case 2:
My king, at most 2 roads can be built.

Hint
Huge input, scanf is recommended.
题意:
有两种城市,富有(并不是有钱,而是有一种富有的资源,用一个数字N标记其富有的资源)和贫穷(并不是没钱,而是缺乏一种资源,用一个数字N标记其缺乏的资源)城市,富有城市的非常希望贫穷城市能够从富有城市进口他们所要的资源,所以决定在富有城市和贫穷城市之间修建道路,但是只有贫穷城市缺乏的资源刚好是富有城市富有资源之间的城市才能建立道路,并且道路不能出现交叉的现象。问你最多能修建几条道路。
富有和贫穷是一一对应的

思路:

把一边从小到大排序,求另一边的最长上升子序列
(两种城市从左到右都是1~n,但是输入的时候可能不是按顺序输,所以要把一边从小到大排序)

这道题数据有点大,<mark>用那个NlogN的方法求最长子序列</mark>

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=5e5+5;
int a[maxn],b[maxn];
int main(){
	int n,Case=0,p,r;
	while(~scanf("%d",&n)){
		int t=0;
		for(int i=1;i<=n;i++){
	    	scanf("%d%d",&p,&r);
		    a[p]=r;
	    }
		for(int i=1;i<=n;i++){
			if(a[i]>b[t]) b[++t]=a[i];
			else{
				int l=1,r=t,mid;
				while(l<=r){
					mid=(l+r)>>1;
					if(b[mid]<=a[i]) l=mid+1;
					else r=mid-1;
				}
				b[l]=a[i];
			}
		}
		if(t==1) printf("Case %d:\nMy king, at most 1 road can be built.\n\n",++Case);
		else printf("Case %d:\nMy king, at most %d roads can be built.\n\n",++Case,t);
	}
	return 0;
}