题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1253
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

Input

输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

Output

对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input

1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0

Sample Output

11

Problem solving report:

Description: 判断在t秒内能不能从(0, 0, 0)到达(A-1, B-1, C-1)。
Problem solving: 深搜和广搜都可以,广搜好写,深搜的话必须要剪枝,记忆化搜索。

Accepted Code:

//DFS
#include <bits/stdc++.h>
using namespace std;
const int inf = 0x3f3f3f3f;
int l, r, c, t, min_;
int dp[55][55][35], mp[55][55][55];
int dir[6][3] = {{0, 0, 1}, {0, 0, -1}, {0, 1, 0}, {0, -1, 0}, {1, 0, 0}, {-1, 0, 0}};
void DFS(int x, int y, int z, int s) {
    int tx, ty, tz;
    if (x + y + z + t < l + r + c + s - 3 || s > t || s >= min_)
        return ;
    if (x == l - 1 && y == r - 1 && z == c - 1) {
        min_ = s;
        return ;
    }
    for (int i = 0; i < 6; i++) {
        tx = x + dir[i][0];
        ty = y + dir[i][1];
        tz = z + dir[i][2];
        if (tx >= 0 && tx < l && ty >= 0 && ty < r && tz >= 0 && tz < c && !mp[tx][ty][tz] && (dp[tx][ty][tz] > s + 1 || !dp[tx][ty][tz])) {
            mp[tx][ty][tz] = 1;
            dp[tx][ty][tz] = s + 1;
            DFS(tx, ty, tz, s + 1);
            mp[tx][ty][tz] = 0;
        }
    }
}
int main() {
    int kase;
    scanf("%d", &kase);
    while (kase--) {
        min_ = inf;
        scanf("%d%d%d%d", &l, &r, &c, &t);
        memset(dp, 0, sizeof(dp));
        for (int i = 0; i < l; i++)
            for (int j = 0; j < r; j++)
                for (int k = 0; k < c; k++)
                    scanf("%d", &mp[i][j][k]);
        DFS(0, 0, 0, 0);
        if (min_ < inf)
            printf("%d\n", min_);
        else printf("-1\n");
    }
    return 0;
}
//BFS
#include <bits/stdc++.h>
using namespace std;
bool vis[55][55][55];
int l, r, c, t, mp[55][55][55];
int dir[6][3] = {{0, 0, 1}, {0, 0, -1}, {0, 1, 0}, {0, -1, 0}, {1, 0, 0}, {-1, 0, 0}};
struct edge {
    int x, y, z, t;
    edge(int x_, int y_, int z_, int t_) {
        x = x_, y = y_, z = z_, t = t_;
    }
}p(0, 0, 0, 0);
int BFS(int x, int y, int z) {
    int tx, ty, tz;
    queue <edge> Q;
    vis[x][y][z] = true;
    Q.push(edge(x, y, z, 0));
    while (!Q.empty()) {
        p = Q.front();
        Q.pop();
        if (p.x == l - 1 && p.y == r - 1 && p.z == c - 1)
            return p.t;
        if (p.t >= t)
            return -1;
        for (int i = 0; i < 6; i++) {
            tx = p.x + dir[i][0];
            ty = p.y + dir[i][1];
            tz = p.z + dir[i][2];
            if (tx >= 0 && tx < l && ty >= 0 && ty < r && tz >= 0 && tz < c && mp[tx][ty][tz] != 1 && !vis[tx][ty][tz]) {
                vis[tx][ty][tz] = true;
                Q.push(edge(tx, ty, tz, p.t + 1));
            }
        }
    }
    return -1;
}
int main() {
    int kase;
    scanf("%d", &kase);
    while (kase--) {
        scanf("%d%d%d%d", &l, &r, &c, &t);
        memset(vis, false, sizeof(vis));
        for (int i = 0; i < l; i++)
            for (int j = 0; j < r; j++)
                for (int k = 0; k < c; k++)
                    scanf("%d", &mp[i][j][k]);
        int ans = BFS(0, 0, 0);
        printf("%d\n", ans);
    }
    return 0;
}