题干:
Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).
Input
The first line contains the integer T indicating to the number of test cases.
For each test case, the first line contains the integers n and B.
Following n lines provide the information of each item.
The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.
1 <= number of test cases <= 100
1 <= n <= 500
1 <= B, w[i] <= 1000000000
1 <= v[1]+v[2]+...+v[n] <= 5000
All the inputs are integers.
Output
For each test case, output the maximum value.
Sample Input
1 5 15 12 4 2 2 1 1 4 10 1 2
Sample Output
15
解题报告:
因为这题质量太大了,所以把质量当成价值,价值当成重量,dp[ j ]表示,买到价值j的物品所需要的最小质量。跑0-1背包就可以了。贴一道类似题目【nyoj - 860】 又见0-1背包
AC代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int INF = 0x3f3f3f3f;
int w[505],v[505];
int dp[10000 + 5];
int n,m;
int main()
{
int t;
scanf("%d",&t);
while(t--) {
scanf("%d%d",&n,&m);
int sum = 0;
for(int i = 1; i<=n; i++) {
scanf("%d%d",&w[i],&v[i]);
sum += v[i];
}
memset(dp,INF,sizeof(dp));
dp[0] = 0;
for(int i = 1; i<=n; i++) {
for(int j = sum; j>=v[i]; j--) {
dp[j] = min(dp[j],dp[j - v[i]] + w[i]) ;
}
}
int ans = 0;
for(int i = sum; i>=0; i--) {
if(dp[i] <= m) {
ans = i;break;
}
}
printf("%d\n",ans);
}
return 0 ;
}