题目链接:https://cn.vjudge.net/problem/ZOJ-3726
题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3726

Alice is providing print service, while the pricing doesn’t seem to be reasonable, so people using her print service found some tricks to save money.

For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It’s easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.

Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.

Input
The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.

Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 105). The second line contains 2n integers s1, p1, s2, p2, …, sn, pn (0=s1 < s2 < … < sn ≤ 109, 109 ≥ p1 ≥ p2 ≥ … ≥ pn ≥ 0). The price when printing no less than si but less than si+1 pages is pi cents per page (for i=1…n-1). The price when printing no less than sn pages is pn cents per page. The third line containing m integers q1 … qm (0 ≤ qi ≤ 109) are the queries.

Output
For each query qi, you should output the minimum amount of money (in cents) to pay if you want to print qi pages, one output in one line.

Sample Input
1
2 3
0 20 100 10
0 99 100
Sample Output
0
1000
1000

题意:

打印店有n个区间,在每个区间内有一个打印价钱即
要打印的张数在[s1,s2),[s 1,s 2)内价钱为p1 ,在[s2,s3) ,[s 2,s 3)内价p2,当大于等于sn 时价钱为pn,题目保证(0=s1 < s2 < … < sn ≤ 109, 109 ≥ p1 ≥ p2 ≥ … ≥ pn ≥ 0)
有m次询问,每次询问有一个要打印的总数,求每次询问打印q张所需要的最小费用

解题思路:贪心+二分查找

首先要知道q在哪一个[s i,si+1)区间内,所以直接二分就可以了找到这个区间就可以了,但是有可能往后面买更多的话反而比较便宜,所以我们可以从最后往前扫一遍,如果前一个的花费比后一个要大,那直接买下一个的张数就可以了,我们弄一个数组,从后扫存两个乘积的较小值就可以了,然后比较一下只买q张和买后面的张数哪个更优就可以了。
这里用到c++的 upper_bound 如果不了解 可以看看这篇文章here

#include <cstdio>
#include <algorithm>
#include <iostream>
#define LL long long
using namespace std;
const int maxn=100017;
LL s[maxn],p[maxn],c[maxn];
int main()
{
    int T;
    int n, m;
    LL tt;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i = 0; i < n; i++)
        {
            scanf("%lld%lld",&s[i],&p[i]);
        }

        LL minn = 9999999999999999;//找最小值
        for(int i = n-1; i >= 0; i--)//从后往前找
        {
            minn = min(s[i]*p[i],minn);
            c[i] = minn;
        }
        for(int i = 0; i < m; i++)
        {
            scanf("%lld",&tt);
            if(tt>=s[n-1])
                printf("%lld\n",tt*p[n-1]);
            else
            {
                int pos = upper_bound(s,s+n,tt)-s;
                LL ans = tt*p[pos-1];
                ans = min(ans,c[pos]);
                printf("%lld\n",ans);
            }
        }
    }
    return 0;
}