7-32 文件传输 (25 分)
当两台计算机双向连通的时候,文件是可以在两台机器间传输的。给定一套计算机网络,请你判断任意两台指定的计算机之间能否传输文件?
输入格式:
首先在第一行给出网络中计算机的总数 N (2≤N≤10
4
),于是我们假设这些计算机从 1 到 N 编号。随后每行输入按以下格式给出:
I c1 c2
其中I表示在计算机c1和c2之间加入连线,使它们连通;或者是
C c1 c2
其中C表示查询计算机c1和c2之间能否传输文件;又或者是
S
这里S表示输入终止。
输出格式:
对每个C开头的查询,如果c1和c2之间可以传输文件,就在一行中输出"yes",否则输出"no"。当读到终止符时,在一行中输出"The network is connected.“如果网络中所有计算机之间都能传输文件;或者输出"There are k components.”,其中k是网络中连通集的个数。
输入样例 1:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S
输出样例 1:
no
no
yes
There are 2 components.
输入样例 2:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S
输出样例 2:
no
no
yes
yes
The network is connected.
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1e4+5;
int pre[maxn];
int find(int x){
return x==pre[x]?x:pre[x]=find(pre[x]);
}
void merge(int x,int y){
int fx=find(x);
int fy=find(y);
if(fx!=fy)
pre[fx]=fy;
}
int main(){
int n,x,y;
char c;
scanf("%d",&n);
getchar();
for(int i=1;i<=n;i++)
pre[i]=i;
while(scanf("%c",&c)){
if(c=='S') {
int ans=0;
for(int i=1;i<=n;i++){
if(i==pre[i]) ans++;
}
if(ans==1)
printf("The network is connected.\n");
else
printf("There are %d components.\n",ans);
break;
}
else if(c=='I'){
scanf("%d%d",&x,&y);
getchar();
merge(x,y);
}
else if(c=='C'){
scanf("%d%d",&x,&y);
getchar();
if(find(x)==find(y))
printf("yes\n");
else
printf("no\n");
}
}
return 0;
}