题目链接http://acm.hdu.edu.cn/showproblem.php?pid=6343

There is a complete graph containing n vertices, the weight of the i-th vertex is wi. 
The length of edge between vertex i and j (i≠j) is ⌊|wi−wj|−−−−−−−√⌋⌊|wi−wj|⌋. 
Calculate the length of the shortest path from 1 to n 

Input 
The first line of the input contains an integer T (1≤T≤10) denoting the number of test cases. 
Each test case starts with an integer n (1≤n≤105) denoting the number of vertices in the graph. 
The second line contains n integers, the i-th integer denotes wi (1≤wi≤105) 

Output 
For each test case, print an integer denoting the length of the shortest path from 1 to n 

Sample Input

1

3

1 3 5

Sample Output

2

AC代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
int m[100005];
int main()
{
    int t,n,s,w;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(s=0;s<n;s++)
            cin>>m[s];
        w=sqrt(abs(m[0]-m[n-1]));
        cout<<w<<endl;
    }
    return 0;
}