H题;
In this problem you need to make a triangle ,just like the sample out. The element in the ith row and jth column
should be the product(乘积) of i and j.
Input
The first line of input is an integer C which indicate the number of test cases.
Then C test cases follow.Each test case contains an integer N (1<=N<=20) in a line which mentioned above.
Output
For each test case, print out the triangle. the triangle separated by a blank line.
If the product is more than 9 (product > 9) you should print a space, or you should print two space.The final number of each line don’t need print space.
Sample Input
3
5
6
7
Sample Output
1 2 3 4 5
2 4 6 8
3 6 9
4 8
5
1 2 3 4 5 6
2 4 6 8 10
3 6 9 12
4 8 12
5 10
6
1 2 3 4 5 6 7
2 4 6 8 10 12
3 6 9 12 15
4 8 12 16
5 10 15
6 12
7
题意: 打印三角形,ij的值的打印;
解题思路: 输出数字按格式输出即可,ij,那么就两层for循环,输出时,注意判断数字是否小于九,是则后面一个空格,否则要有两个空格;那么输出的数字规律是:i*j;
特别要注意的是打印的格式;
乘积小于9每个数之见按一个空格,大于等于九就 是两个空格;
#include<cstdio>
#include<cstring>
#include<cmath
#include<algorithm>
#include<iostream>
using namespace std;
int main()
{
int n,m,t=0;
scanf("%d",&n);
while(n--)
{
scanf("%d",&m);
int s=m;
for(int i=1;i<=m;i++)
{
for(int j=1;j<=s;j++)
{
printf("%d",i*j);
if(i*j>9&&j!=s)
printf(" ");
else if(i*j<=9&&j!=s)
printf(" ");//小于九则打印两个空格;
}
printf("\n");
s--;
}
if(n)
printf("\n");
}
return 0;
}