Aggressive cows

Time Limit: 1000MS Memory Limit: 65536K

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

  • Line 1: Two space-separated integers: N and C

  • Lines 2…N+1: Line i+1 contains an integer stall location, xi
    Output

  • Line 1: One integer: the largest minimum distance
    Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

思路:

要是最小的尽可能最大,先用二分去找到那个最小值,在刚开始找的时候假如最小值过大,那么肯定没有能够到达的棚子,比如1 2 5, 但是你的二分找的最小值为8,那么只有一只牛可以住牛舍,所以就将r缩小,假如棚子够的话,就将l增大,最大就可以求出最小值了。

#include <iostream>
#include <algorithm>
using namespace std;
int a[100010];
int n, m;
int check(int mid) {
	int start = 0, sum = 1;
	for (int i = 1; i < n; i++) {
		if (a[i] - a[start] >= mid) {
			start = i;
			sum++;	
		}
	}
	return sum;
}
int main() {
	scanf("%d %d", &n, &m);
	for (int i = 0; i < n; i++) scanf("%d", &a[i]);
	sort(a, a + n);
	int l = 0, r = 0x7fffffff;
	while (l <= r) {
		int mid = (l + r) >> 1;
		if (check(mid) < m) r = mid - 1;
		else l = mid + 1;
	}
	cout << r;
	return 0;
}