题目链接:http://poj.org/problem?id=2243

Time Limit: 1000MS   Memory Limit: 65536K

Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy. 
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. 
Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input

The input will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

Problem solving report:

Description: 一个棋盘,求给定两个方格之间骑士移动的最小数量。
Problem solving: 二维坐标,求一个点到另外一个点的最短步数,广搜一下就行了,a~h作为横坐标,1~8作为纵坐标。

#include <stdio.h>
#include <string.h>
int ax, bx, temp, head, tail;
int vis[10][10], next[8][2] = {1, 2, 1, -2, -1, 2, -1, -2, 2, 1, 2, -1, -2, 1, -2, -1};
struct node {
    char x;
    int y, s;
}que[100];
int main()
{
    int t2, ty, ay, by;
    char t1, tx, ax, bx;
    while (~scanf("%c%d %c%d%*c", &ax, &ay, &bx, &by))
    {
        if (ax == bx && ay == by)
        {
            printf("To get from %c%d to %c%d takes 0 knight moves.\n", ax, ay, bx, by);
            continue;
        }
        temp = 0;
        memset(vis, 0, sizeof(vis));
        head = tail= 1;
        que[tail].x = ax;
        que[tail].y = ay;
        que[tail++].s = 0;
        vis[ax - 'a'][ay] = 1;
        while (head < tail)
        {
            t1 = que[head].x;
            t2 = que[head].y;
            for (int k = 0; k < 8; k++)
            {
                tx = t1 + next[k][0];
                ty = t2 + next[k][1];
                if (tx < 'a' || tx > 'h' || ty < 1 || ty > 8 || vis[tx - 'a'][ty])
                    continue;
                vis[tx - 'a'][ty] = 1;
                que[tail].x = tx;
                que[tail].y = ty;
                que[tail++].s = que[head].s + 1;
                if (tx == bx && ty == by)
                {
                    temp = 1;
                    break;
                }
            }
            if (temp)
                break;
            head++;
        }
        printf("To get from %c%d to %c%d takes %d knight moves.\n", ax, ay, bx, by, que[tail - 1].s);
    }
    return 0;
}