题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1586
Time Limit: 2 Seconds Memory Limit: 65536 KB

Problem Description

In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

A sample is shown below:

A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.

Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.

Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.

Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0

Sample Output

370

Problem solving report:

Description: 给你一个n表示有n个点然后给你n个数,表示该站点每连一条线时需要的自身的消耗(适配器价格),然后输入n*n的矩阵:第i行第j列的数代表第i个站点和第j个站点之间路上的花费,最后求各个点想通所需要的最小花费。
Problem solving: 计算建立QS网络的最小费用——最小生成树问题。构造连通网时,每条边权值 = 两端QS的适配器价格 + 这两个QS之间网线的价格。

Accepted Code:

/* 
 * @Author: lzyws739307453 
 * @Language: C++ 
 */
#include <queue>
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
const int MAXN = 1005;
const int MAXM = MAXN * MAXN;
const int inf = 0x3f3f3f3f;
bool vis[MAXN];
int mp[MAXN][MAXN], dis[MAXN], v[MAXN];
struct edge {
    int v, w;
    edge() {}
    edge(int v, int w) : v(v), w(w) {}
    bool operator < (const edge &s) const {
        return s.w < w;
    }
};
int prim(int s, int n) {
    priority_queue <edge> Q;
    for (int i = 1; i <= n; i++) {
        vis[i] = 0;
        dis[i] = inf;
    }
    dis[s] = 0;
    Q.push(edge(s, dis[s]));
    int ans = 0;
    while (!Q.empty()) {
        edge u = Q.top();
        Q.pop();
        if (vis[u.v])
            continue;
        vis[u.v] = 1;
        ans += u.w;
        for (int j = 1; j <= n; j++) {
            if (!vis[j] && dis[j] > mp[u.v][j]) {
                dis[j] = mp[u.v][j];
                Q.push(edge(j, dis[j]));
            }
        }
    }
    return ans;
}
int main() {
    int n, m, t;
    scanf("%d", &t);
    while (t--) {
        scanf("%d", &n);
        memset(vis, 0, sizeof(vis));
        for (int i = 1; i <= n; i++)
            scanf("%d", &v[i]);
        for (int i = 1; i <= n; i++) {
            for (int j = 1; j <= n; j++) {
                scanf("%d", &mp[i][j]);
                mp[i][j] += v[i] + v[j];
            }
        }
        printf("%d\n", prim(1, n));
    }
    return 0;
}