题目链接:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=477
Time limit: 3.000 seconds

Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:
                                        D
                                       / \
                                      /   \
                                     B     E
                                    / \     \
                                   /   \     \
                                  A     C     G
                                             /
                                            /
                                           F
To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree).
For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later(but she never tried it).
Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!

Input

The input file will contain one or more test cases.
Each test case consists of one line containing two strings ‘preord’ and ‘inord’, representing the
preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters.
(Thus they are not longer than 26 characters.)
Input is terminated by end of file.

Output

For each test case, recover Valentine’s binary tree and print one line containing the tree’s postorder
traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB

Problem solving report:

Description: 给出二叉树的先序遍历和中序遍历,求后序遍历。
Problem solving: 利用先序和后序的性质,递归模拟一下就行了。

#include <stdio.h>
#include <string.h>
int pst;
char preorder[30], inorder[30];
void solve(int l, int r)
{
    int i;
    char root = preorder[pst];
    if (l >= r)
        return;
    for (i = l; i < r; i++)
        if (inorder[i] == preorder[pst])
            break;
    pst++;
    solve(l, i);
    solve(i + 1, r);
    printf("%c", root);
}
int main()
{
    while (~scanf("%s%s", preorder, inorder))
    {
        pst = 0;
        solve(0, strlen(inorder));
        printf("\n");
    }
    return 0;
}