Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

题意:

    有n个城市分别以1~n命名,这些城市之间有m条道路,每条道路都有一个承载量。让你找一条路径,使城市1到城市n路径中承载量最小的道路尽可能的大。(尽可能的多拉货,所以尽可能大的称重量)

思路:

     最小路的变形,改下松弛条件就行了。dis数组先找出最大的值进行比较,更新dis数组。

   这题还挺绕的,别把自己绕迷了,反正我是迷了好大会。

代码:

#include<stdio.h>
#include<string.h>
int e[1001][1001];
int dis[1001],book[1001];
int minn(int x,int y)
{
	if(x>y)
		return y;
	else
		return x;
}
int main()
{
	int t,n,m,a,b,c,i,j,k,min,maxx,u,flag=0;

	scanf("%d",&t);
	while(t--)
	{
		memset(e,0,sizeof(e));
		memset(book,0,sizeof(book));
		flag++;
		scanf("%d%d",&n,&m);
		while(m--)
		{
			scanf("%d%d%d",&a,&b,&c);
			e[a][b]=c;
			e[b][a]=c;
		}
		for(i=1;i<=n;i++)
			dis[i]=e[1][i];
		for(i=1;i<=n;i++)
			book[i]=0;
		book[1]=1;
		for(i=1;i<=n;i++)
		{
			maxx=-1;
			for(j=1;j<=n;j++)
			{
				if(book[j]==0&&dis[j]>maxx)
				{
					maxx=dis[j];
					u=j;
				}
			}
			book[u]=1;
			for(k=1;k<=n;k++)
			{
				if(book[k]==0&&dis[k]<minn(dis[u],e[u][k]))
					dis[k]=minn(dis[u],e[u][k]);
			}	
		}
		printf("Scenario #%d:\n",flag);
		printf("%d\n\n",dis[n]);
	}
}