Farm Irrigation


Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.


Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE

then the water pipes are distributed like


Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

Output

For each test case, output in one line the least number of wellsprings needed.

Sample Input

2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1

Sample Output

2
3

题意:

      给你管道的位置,相通的管道一口井,问最少需要多少井。

思路:

      把A~K块管道按“右 下 左 上”的顺序存在一个数组中,通记为1,不通记为0.然后进行深搜。

代码:

#include<stdio.h>
#include<string.h>
int m,n;
char map[60][60];
int book[60][60];
void dfs(int x,int y)
{
	int tx,ty,k;
	int next[4][2]={0,1, 1,0, 0,-1, -1,0};
	int mapp[11][4]={0,0,1,1, 
					1,0,0,1,  
					0,1,1,0, 
					1,1,0,0, 
					0,1,0,1, 
					1,0,1,0,
					1,0,1,1, 
					0,1,1,1, 
					1,1,1,0, 
					1,1,0,1, 
					1,1,1,1
	};
	for(k=0;k<4;k++)
	{
		tx=x+next[k][0];
		ty=y+next[k][1];
		if(tx<0||tx>=n||ty<0||ty>=m)
			continue;
		if(book[tx][ty]==0)
		{
			if(k==0)
			{
				if(mapp[map[x][y]-'A'][0]!=0&&mapp[map[tx][ty]-'A'][2]!=0)//向右搜 
				{
					book[tx][ty]=1;
					dfs(tx,ty);
				}
			}
			else if(k==1)
			{
				if(mapp[map[x][y]-'A'][1]!=0&&mapp[map[tx][ty]-'A'][3]!=0)//向下搜 
				{
					book[tx][ty]=1;
					dfs(tx,ty);
				}
			} 
			else if(k==2)
			{
				if(mapp[map[x][y]-'A'][2]!=0&&mapp[map[tx][ty]-'A'][0]!=0)//向左搜 
				{
					book[tx][ty]=1;
					dfs(tx,ty);
				}
			} 
			else if(k==3)
			{
				if(mapp[map[x][y]-'A'][3]!=0&&mapp[map[tx][ty]-'A'][1]!=0)//向上搜 
				{
					book[tx][ty]=1;
					dfs(tx,ty);
				}
			} 
		}
	 } 
	 return;
}
int main()
{
	int i,j,c;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(n==-1&&m==-1)
			break;
		c=0;
		memset(book,0,sizeof(book));
		getchar();
		for(i=0;i<n;i++)
			scanf("%s",map[i]);
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
			{
				if(book[i][j]==0)
				{
					book[i][j]=1;
					dfs(i,j);
					c++;
				}
			}
		printf("%d\n",c);
	}
	return 0;
 }