Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

题意:

   第一行输入货币的种类数、交换点、Nick持有货币的种类、货币数。

   接下来m行输入的分别是: a,b,c,d,e,f. 表示a到b的汇率为c,佣金为d,b到a的汇率为e,佣金为f。

   问Nick通过兑换不同种类的货币,能否使钱增多。就是判断回路中是否存在正权回路。

思路:

   利用Bellman-Ford判断是否含有正权回路。用Bellman-Ford与判断负权回路一样只不过判断负权回路dis数组初始化最大,判断正权回路只要初始化最小就好了。

代码:

#include<stdio.h>
#include<string.h>
int main()
{
	int n,m,s;
	double t,c[110],d[110],e[110],f[110];
	int a[110],b[110],i,j,flag,check;
	double dis[110];
	while(scanf("%d%d%d%lf",&n,&m,&s,&t)!=EOF)
	{
		memset(dis,0,sizeof(dis));
		dis[s]=t;
		for(i=1;i<=m;i++)
		{
			scanf("%d%d%lf%lf%lf%lf",&a[i],&b[i],&c[i],&d[i],&e[i],&f[i]);
		}
		for(i=1;i<=n-1;i++)
		{
			check=0;
			for(j=1;j<=m;j++)
			{
				if((dis[a[j]]-d[j])*c[j]>dis[b[j]])
				{
					dis[b[j]]=(dis[a[j]]-d[j])*c[j];
					check++;
				}
				if((dis[b[j]]-f[j])*e[j]>dis[a[j]])
				{
					dis[a[j]]=(dis[b[j]]-f[j])*e[j];
					check++;
				}
			}
			if(check==0)
				break;
		}
		flag=0;
		for(i=1;i<=m;i++)
		{
			if((dis[a[i]]-d[i])*c[i]>dis[b[i]])
			{
				flag++;
				break;
			}
			if((dis[b[i]]-f[i])*e[i]>dis[a[i]])
			{
				flag++;
				break;
			}
		}
		if(flag)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}