阿生的小球

Description

 

阿生有一定的精神障碍,他有一堆小球,这些小球陪伴了他许多年,是他的精神寄托。每个小球从1到n编号,有自己的质量,现在他想知道任意两个位置间的小球中质量最小的小球,你可以帮帮他吗?

Input

 

输入中第一行有两个数m,n表示有m(m<=100000)个小球,n表示有n个问题,n<=100000。

第二行为m个数,分别是小球的质量

后面n行分别是n个问题,每行有2个数字说明开始结束的小球编号。

Output

 

输出文件中为每个问题的答案。具体查看样例。

Sample Input 1 

10 3
1 2 3 4 5 6 7 8 9 10
2 7
3 9
1 10

Sample Output 1

2 3 1

 

由于大部分人做不上来,测试样例就改小了,直接遍历就能过~~~~。

#include<iostream>
#include<vector>
using namespace std;
int main(){
	int m,n;
	cin>>m>>n;
	vector<int>num(m+1);
	for(int i=1;i<=m;i++){
		cin>>num[i];
	}
	int flag=0;
	for(int i=0;i<n;i++){
		int a,b;
		cin>>a>>b;
		int min=num[a];
		for(int l=a+1;l<=b;l++){
			if(min>num[l]){
				min=num[l];
			}
		}
		if(flag){
			cout<<" ";
			
		}flag=1;
		cout<<min;
	}
	return 0;
}

这题和吃 胖了的阿生 是一道姊妹题