Card Trick

Time Limit: 1000MS Memory Limit: 65536K

Description

The magician shuffles a small pack of cards, holds it face down and performs the following procedure:

The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.
Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.
Three cards are moved one at a time…
This goes on until the nth and last card turns out to be the n of Spades.
This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of the cards for a given number of cards, 1 ≤ n ≤ 13.

Input

On the first line of the input is a single positive integer, telling the number of test cases to follow. Each case consists of one line containing the integer n.

Output

For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…

Sample Input

2
4
5

Sample Output

2 1 4 3
3 1 4 5 2

题意:

每次将i张牌放在牌底,然后最顶上的牌是i,问开始时候的序列。

思路:

逆向分析,先将第n张牌放在顶,然后从最后将n张牌往前放,这样不断模拟,最后从头到尾输出就行了。

#include <iostream>
#include <cstdio>
#include <deque>
using namespace std;
int main() {
    ios::sync_with_stdio(false);
    int t, n;
    scanf("%d", &t);
    while (t--) {
        scanf("%d", &n);
        deque<int> q;
        for (int i = n; i >= 1; i--) {
            q.push_front(i);
            for (int j = 1; j <= i; j++) {
                int now = q.back();
                q.pop_back();
                q.push_front(now);
            }
        }
        while (!q.empty()) {
            printf("%d ", q.front());
            q.pop_front();
        }
        printf("\n");
    }
    return 0;
}