Computer

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 38471 Accepted Submission(s): 6981

Problem Description
A school bought the first computer some time ago(so this computer’s id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.

Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).

Sample Input
5
1 1
2 1
3 1
1 1

Sample Output
3
2
3
4
4

Author
scnu


没什么难度,求出树的直径即可,再预处理出直径的端点到所有点的距离即可。

注意输入。


AC代码:

#pragma GCC optimize(2)
#include<bits/stdc++.h>
//#define int long long
using namespace std;
const int N=1e4+10;
int n,d1[N],d2[N],p1,p2;
int head[N],to[N<<1],nex[N<<1],w[N<<1],tot;
inline void add(int a,int b,int c){
	to[++tot]=b; nex[tot]=head[a]; w[tot]=c; head[a]=tot;
}
inline void init(){
	tot=0;	memset(head,0,sizeof head);
	memset(d1,0,sizeof d1);	memset(d2,0,sizeof d2);
}
int bfs(int x){
	int res=x,mx=1,vis[N]={0};	queue<int> q;	q.push(x);	vis[x]=1;
	while(q.size()){
		int u=q.front();	q.pop();
		for(int i=head[u];i;i=nex[i]){
			if(!vis[to[i]]){
				vis[to[i]]=vis[u]+w[i];	q.push(to[i]);
				if(vis[to[i]]>mx)	mx=vis[to[i]],res=to[i];
			}
		}
	}
	return res;
}
void bfs1(int x,int d[]){
	d[x]=1;	queue<int> q;	q.push(x);
	while(q.size()){
		int u=q.front();	q.pop();
		for(int i=head[u];i;i=nex[i]){
			if(!d[to[i]]){
				d[to[i]]=d[u]+w[i];	q.push(to[i]);
			}
		}
	}
}
signed main(){
	while(~scanf("%d",&n)){
		init();
		for(int i=2;i<=n;i++){
			int a,b;	scanf("%d %d",&a,&b);	
			add(i,a,b);	add(a,i,b);
		}
		p1=bfs(1);	p2=bfs(p1);	bfs1(p1,d1);	bfs1(p2,d2);
		for(int i=1;i<=n;i++)	printf("%d\n",max(d1[i],d2[i])-1);
	}
	return 0;
}