数据结构实验之链表七:单链表中重复元素的删除

Time Limit: 1000MS  Memory Limit: 65536KB

Problem Description

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

Input

第一行输入元素个数 n (1 <= n <= 15);
第二行输入 n 个整数,保证在 int 范围内。

Output

第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

Example Input

10
21 30 14 55 32 63 11 30 55 30

Example Output

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

Hint

Author

不得使用数组!

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct node
{
    int data;
    struct node * next;

};
int main()
{
    int n,i;
    struct node *p, *q, *head, *tail;
    head = (struct node *)malloc(sizeof(struct node));
    head->next = NULL;
    scanf("%d", &n);
    for(i = 0; i < n; i++)
    {
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d", &p->data);
        p->next = head->next;
        head->next = p;
    }
    q = head->next;
    printf("%d\n", n);
    for(i = 0; i < n; i++)
    {
        printf("%d", q->data);
        if(i==n-1)
            printf("\n");
        else
            printf(" ");
        q = q->next;
    }
    for(q = head->next; q->next!=NULL;)
    {
        for(tail = q,p=tail->next; p!=NULL; )
        {
            if(p->data==q->data)
            {
                tail->next = p->next;
                
                n--;
                break;
            }
            else
            {
                tail = tail->next;
                p = tail->next;
            }
        }
        if(p!=NULL)
        {
            q = q;
        }
        else
            q = q->next;
    }
    printf("%d\n", n);
    for(q = head->next; q != NULL; q=q->next)
    {
        printf("%d", q->data);
        if(q->next == NULL)
        {
            printf("\n");
        }
        else
            printf(" ");
    }
    return 0;
}
再上个c++的
#include<bits/stdc++.h>
using namespace std;
struct node
{
    int data;
    struct node *next;
};
int main()
{
    int n, i;
    struct node *head, *t, *p, *q;
    cin>>n;
    head = new node;
    head->next = NULL;
    q = head;
    for(i = 0; i < n; i++)
    {
        p = new node;
        cin>>p->data;
        p->next = head->next;
        head->next = p;
    }
    q = head->next;
    cout<<n<<endl;
    while(q)
    {
        cout<<q->data;
        if(q->next)
            cout<<" ";
        else
            cout<<endl;
        q = q->next;
    }
    for(q = head->next;q->next;)
    {
        for(t = q,p = t->next;p;)
        {
            if(q->data == p->data)
            {
                t->next = p->next;
                n--;
                break;
            }
            else
            {
                t = t->next;
                p = p->next;
            }
        }
        if(p)
            q = q;
        else
            q = q->next;

    }
    cout<<n<<endl;
    q = head->next;
    while(q)
    {
        cout<<q->data;
        if(q->next)
            cout<<" ";
        else
            cout<<endl;
        q = q->next;

    }
    return 0;
}