题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4342
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

Tom took the Discrete Mathematics course in the 2011,but his bad attendance angered Professor Lee who is in charge of the course. Therefore, Professor Lee decided to let Tom face a hard probability problem, and announced that if he fail to slove the problem there would be no way for Tom to pass the final exam.
As a result , Tom passed.
History repeat itself. You, the bad boy, also angered the Professor Lee when September Ends. You have to faced the problem too.
The problem comes that You must find the N-th positive non-square number M and printed it. And that's for normal bad student, such as Tom. But the real bad student has to calculate the formula below.


So, that you can really understand WHAT A BAD STUDENT YOU ARE!!

Input

There is a number (T)in the first line , tell you the number of test cases below. For the next T lines, there is just one number on the each line which tell you the N of the case.
To simplified the problem , The N will be within 231 and more then 0.

Output

For each test case, print the N-th non square number and the result of the formula.

Sample Input

4
1
3
6
10

Sample Output

2 2
5 7
8 13
13 28

Problem solving report:

Description: 求第n个非平方数,求前n个数的sqrt(i)和
Problem solving: 求第n个非平方数,假设为y,y之前有x个平方数,则y=n+x,且sqrt(n+x)=x,可以得出y;
求前n个数的sqrt(i)和:分段求就好了。

Accepted Code:

#include <bits/stdc++.h>
using namespace std;
int main() {
    int t, n, l, k;
    long long ans, r;
    scanf("%d", &t);
    while (t--) {
        l = 1;
        ans = 0;
        scanf("%d", &n);
        while ((int)sqrt(n + l) != l)
            l++;
        r = l + n;
        k = (int)sqrt(r);
        for (int i = 2; i <= k; i++)
            ans += 1ll * (i * i - (i - 1) * (i - 1)) * (i - 1);
        ans += (r - k * k + 1) * k;
        printf("%d %lld\n", r, ans);
    }
    return 0;
}