超级台阶
时间限制:1000 ms | 内存限制:65535 KB
难度:3

描述
有一楼梯共m级,刚开始时你在第一级,若每次只能跨上一级或二级,要走上第m级,共有多少走法?
注:规定从一级到一级有0种走法。

输入
输入数据首先包含一个整数n(1<=n<=100),表示测试实例的个数,然后是n行数据,每行包含一个整数m,(1<=m<=40), 表示楼梯的级数。
输出
对于每个测试实例,请输出不同走法的数量。
样例输入
2
2
3
样例输出
1
2

代码:

#include<iostream>
#include<stdio.h>

using namespace std;
int a[41]= {0,0,1,2};
int f(int n)
{
    if(n==1)
        return 0;
    if(a[n])
        return a[n];
    a[n]=f(n-1)+f(n-2);
    return a[n];
}

int main()
{
    int T,n;
    cin>>T;
    while(T--)
    {
        scanf("%d",&n);
        cout<<f(n)<<endl;
    }
    return 0;
}