问题描述


Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.

Input
The input will consist of a series of integers n, one integer per line.

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input
1
100

Sample Output
1

5050

Author
DOOM III

Recommend
We have carefully selected several similar problems for you: 1090 1003 1091 1004 1092


解题思路


防止溢出,对n判断一下是奇数还是偶数,分别处理

代码


#include<iostream>
using namespace std;

int main()
{
    int n;
    int sum = 0;
    while(cin >> n)
    {
        if(n&1) //奇数
            sum = (n+1)/2*n;
        else  //偶数
            sum = n/2*(n+1);
        cout << sum << endl <<endl;
    }
    return 0;
}