Problem Description
In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.
Input
The input contains four parts:
1. a dictionary, which consists of at least one and at most 100 words, one per line;
2. a line containing XXXXXX, which signals the end of the dictionary;
3. one or more scrambled `words' that you must unscramble, each on a line by itself; and
4. another line containing XXXXXX, which signals the end of the file.
All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.
1. a dictionary, which consists of at least one and at most 100 words, one per line;
2. a line containing XXXXXX, which signals the end of the dictionary;
3. one or more scrambled `words' that you must unscramble, each on a line by itself; and
4. another line containing XXXXXX, which signals the end of the file.
All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.
Output
For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.
Sample Input
tarp given score refund only trap work earn course pepper part XXXXXX resco nfudre aptr sett oresuc XXXXXX
Sample Output
score ****** refund ****** part tarp trap ****** NOT A VALID WORD ****** course
******
题目大意:
输入包含四个部分: 1。由至少一个和最多100个单词组成的字典,每行一个; 2。一行xxxxxx,字典的结束信号; 3。输入信号文件 4。另一条线包含xxxxxx,信号文件的结束。
找出字典中和信号文件字母一样的按字典序输出,没有时输出“NOT A VALID WORD”,每个输入后跟“******”。
c++
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
struct zf
{
string a;
};
bool cmp(zf a,zf b)
{
return a.a<b.a;
}
int bj(int a[],int b[])
{
int c;
for(c=0;c<26;c++)
{
if(a[c]!=b[c])
return 0;
}
return 1;
}
int main()
{
zf a[1000],b[1000];
int c[30],m[30];
int d,e,f,g,h,n,l,q,p;
d=0;e=0;
while(1)
{
cin>>a[d].a;
if(a[d].a=="XXXXXX") //跳出字典的输入
break;
d++;
}
sort(a,a+d,cmp); //将字典按字典序排列
while(1)
{
cin>>b[e].a;
if(b[e].a=="XXXXXX") //跳出查找的输入
break;
h=0;
l=b[e].a.size();
for(g=0;g<d;g++)
{
memset(c,0,sizeof(c)); //用来统计查找的字母个数
memset(m,0,sizeof(m)); //用来统计字典的字母个数 n=a[g].a.size();
if(l==n)
{
for(q=0;q<l;q++)
{
c[b[e].a[q]-'a']++;
m[a[g].a[q]-'a']++;
}
p=bj(m,c);
if(p==1)
{
cout<<a[g].a<<endl;
h++;
}
}
}
if(h==0)
{
cout<<"NOT A VALID WORD"<<endl;
}
cout<<"******"<<endl;
e++;
}
return 0;
}