How many integers can you find

Time Limit: 12000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

Input

There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

Output

For each case, output the number.

Sample Input

12 2
2 3

Sample Output

7

思路:

题目要求求出在1-n中有多少个数字可以被后面的ai整除,这样的话就可以用容斥定理,所以就有整除一个的减去整除两个的加上整除三个等等,所以可以用dfs,也可以用二进制的方法,二进制就是枚举出全部的情况,状态中有1的说明这个整除这个ai,有多少个整除多少个,然后根据整除的个数判断时加还是减。

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int gcd(int a, int b) {
    if (b == 0) return a;
    else return gcd(b, a % b);
}
int lcm(int a, int b) {
    return a / gcd(a, b) * b;
}
int main() {
    ios::sync_with_stdio(false);
    int n, m;
    int a[20];
    while (scanf("%d %d", &n, &m) != EOF) {
        int k = 0, x;
        while (m--) {
            scanf("%d", &x);
            if (x) a[k++] = x;
        }
        int ans = 0;
        for (int i = 1; i < 1 << k; i++) {
            int lc = 0, cnt = 0;
            for (int j = 0; j < k; j++) {
                if (i >> j & 1) {
                    cnt++;
                    if (lc == 0) lc = a[j];
                    else lc = lcm(lc, a[j]);
                }
            }
            if (cnt & 1) ans += (n - 1) / lc;
            else ans -= (n - 1) / lc;
        }
        printf("%d\n", ans);
    }
    return 0;
}