Find The Multiple
Time Limit: 1000MS | Memory Limit: 10000K | |||
Total Submissions: 38700 | Accepted: 16149 | Special Judge |
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2 6 19 0
Sample Output
10 100100100100100100 111111111111111111
题意 : 输出任意一个由 0 1组成的十进制数字且该数可以整除 n ,通过dfs来写. 两组条件是,dfs(ans*10) , dfs(ans * 10 + 1).
#include <cstdio>
#include <iostream>
#include <cstring>
#include <cstdlib>
#define ull unsigned long long int
using namespace std;
int flag = 0;
void dfs(ull step , ull n)
{
if(flag == 1)
{
// flag = 0 ;
return ;
}
if(step % n == 0)
{
flag = 1;
cout << step << endl;
return ;
}
if(step > 1000000000000000000)
{
return;
}
dfs(step*10 , n);
dfs(step*10+1 , n);
}
int main()
{
ull n;
while(cin >> n)
{
flag = 0;
if(n == 0)break;
dfs(1 , n);
}
return 0;
}
要注意的一个点:
if(step > 1000000000000000000)
{
return;
}
该式要放在
if(step % n == 0)
{
flag = 1;
cout << step << endl;
return ;
}
之下。