7-36 旅游规划 (25 分)
有了一张自驾旅游路线图,你会知道城市间的高速公路长度、以及该公路要收取的过路费。现在需要你写一个程序,帮助前来咨询的游客找一条出发地和目的地之间的最短路径。如果有若干条路径都是最短的,那么需要输出最便宜的一条路径。
输入格式:
输入说明:输入数据的第1行给出4个正整数N、M、S、D,其中N(2≤N≤500)是城市的个数,顺便假设城市的编号为0~(N−1);M是高速公路的条数;S是出发地的城市编号;D是目的地的城市编号。随后的M行中,每行给出一条高速公路的信息,分别是:城市1、城市2、高速公路长度、收费额,中间用空格分开,数字均为整数且不超过500。输入保证解的存在。
输出格式:
在一行里输出路径的长度和收费总额,数字间以空格分隔,输出结尾不能有多余空格。
输入样例:
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
输出样例:
3 40
#include<cstdio>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
struct node{
int v,w,cost;
node(){}
node(int vv,int ww,int cc){
v=vv;
w=ww;
cost=cc;
}
};
struct Node{
int u,w,cost;
Node(){}
Node(int uu,int ww,int cc){
u=uu;
w=ww;
cost=cc;
}
bool operator<(const Node other)const{
if(w!=other.w) return w>other.w; //距离长的优先级小
else return cost>other.cost; //否则花费大的优先级小
}
};
const int maxn=505;
const int Inf=0x3f3f3f3f;
int N,M,S,D;
vector<node> G[maxn];
bool vis[maxn];
int dis[maxn],cost[maxn];
void Dijkstra(){
priority_queue<Node> q;
for(int i=0;i<N;i++){ //初始化
dis[i]=Inf,cost[i]=Inf;
vis[i]=false;
}
dis[S]=0,cost[S]=0;
q.push(Node(S,dis[S],cost[S]));
while(!q.empty()){
Node temp=q.top();
q.pop();
int u=temp.u;
if(vis[u]) continue;
vis[u]=true;
for(int i=0;i<G[u].size();i++){
node tmp=G[u][i];
int v=tmp.v;
int w=tmp.w;
int c=tmp.cost;
if(dis[v]>dis[u]+w){
dis[v]=dis[u]+w;
cost[v]=cost[u]+c;
q.push(Node(v,dis[v],cost[v]));
continue;
}
if(dis[v]==dis[u]+w&&cost[v]>cost[u]+c){
cost[v]=cost[u]+c;
q.push(Node(v,dis[v],cost[v]));
}
}
}
printf("%d %d\n",dis[D],cost[D]);
}
int main() {
int a,b,w,c;
scanf("%d%d%d%d",&N,&M,&S,&D);
for(int i=0;i<M;i++){
scanf("%d%d%d%d",&a,&b,&w,&c);
G[a].push_back(node(b,w,c));
G[b].push_back(node(a,w,c));
}
Dijkstra();
return 0;
}