题干:

There is a kindom of obsession, so people in this kingdom do things very strictly. 

They name themselves in integer, and there are nn people with their id continuous (s+1,s+2,⋯,s+n)(s+1,s+2,⋯,s+n) standing in a line in arbitrary order, be more obsessively, people with id xx wants to stand at ythyth position which satisfy 

xmody=0xmody=0
Is there any way to satisfy everyone's requirement?

Input

First line contains an integer TT, which indicates the number of test cases. 

Every test case contains one line with two integers nn, ss. 

Limits 
1≤T≤1001≤T≤100. 
1≤n≤1091≤n≤109. 
0≤s≤1090≤s≤109.

Output

For every test case, you should output 'Case #x: y', where x indicates the case number and counts from 1 and y is the result string. 

If there is any way to satisfy everyone's requirement, y equals 'Yes', otherwise yequals 'No'.

Sample Input

2
5 14
4 11

Sample Output

Case #1: No
Case #2: Yes

题目大意:

给定S,N,把S+1,S+2,...S+N这N个数填到1,2,...,N里,要求X只能填到X的因子的位置。(即X%Y=0,那么X才能放在Y位置)。问是否能够放满。

解题报告:

首先打表猜出素数的间隔不会超过300,于是乎如果n大于300,那么就是NO,否则的话就是用那些数字去匹配这些位置,考虑匈牙利算法求解匹配问题。

写完发现怎么都WA,后来发现s==0的时候需要特判,交,WA。然后发现s==1也需要特判,s==2好像也可以特判。。。GG。

赛后知道,因为s和n相差很大的话,中间的都可以抵消掉,所以有多少素数都无所谓,所以可以把s和n互换一下,再去判断。

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
const int MAX = 300 + 5;
double H,h,D;
bool bk[MAX];
bool line[MAX][MAX];
int nxt[MAX];
bool used[MAX];
int n,s;
bool find(int v) {
	for(int i = 1; i<=n; i++) {
		if(!used[i] && line[v][i]) {
			used[i]=1; 
			if(!nxt[i] || find(nxt[i])) {
				nxt[i]=v;
				return 1;
			}
		}
	}
	return 0 ;
}
int match(int m) {
	int res = 0;
	for(int i = 1; i<=m; i++) {
		memset(used,0,sizeof used);
		if(find(i)) res++;
	}
	return res;
}
int main() 
{
	int t;
	cin>>t;
	int iCase = 0;
	while(t--) {
		scanf("%d%d",&n,&s);
		
		if(s == 0 || n == 1 || s == 1 || s == 2) {
			printf("Case #%d: Yes\n",++iCase);continue;
		}
		if(s < n) swap(s,n);
		if(n >= 300) {
			printf("Case #%d: No\n",++iCase);continue;
		}
		ll low = s+1,up = s+n;
		int flag = 1;
		memset(line,0,sizeof line);
		memset(nxt,0,sizeof nxt);
		for(ll i = low; i<=up; i++) {
			for(int j = 1; j<=n; j++) {
				if(i%j==0) line[i-low+1][j] = 1;
			}
		}
		int ans = match(up-low+1);
		if(ans == n) flag = 1;
		else flag = 0;
		if(flag) printf("Case #%d: Yes\n",++iCase);
		else printf("Case #%d: No\n",++iCase);
	}
	return 0 ;
}