题目来源:

https://ac.2333.moe/Problem/view.xhtml?id=1220

https://cn.vjudge.net/contest/290636#problem/D

 

  • 问题描述
  • The National Intelligence Council of X Nation receives a piece of credible information that Nation Y will send spies to steal Nation X’s confidential paper. So the commander of The National Intelligence Council take measures immediately, he will investigate people who will come into NationX. At the same time, there are two List in the Commander’s hand, one is full of spies that Nation Y will send to Nation X, and the other one is full of spies that Nation X has sent to Nation Y before. There may be some overlaps of the two list. Because the spy may act two roles at the same time, which means that he may be the one that is sent from Nation X to Nation Y, we just call this type a “dual-spy”. So Nation Y may send “dual_spy” back to Nation X, and it is obvious now that it is good for Nation X, because “dual_spy” may bring back NationY’s confidential paper without worrying to be detention by NationY’s frontier So the commander decides to seize those that are sent by NationY, and let the ordinary people and the “dual_spy” in at the same time .So can you decide a list that should be caught by the Commander?

    A:the list contains that will come to the NationX’s frontier.

    B:the list contains spies that will be sent by Nation Y.

    C:the list contains spies that were sent to NationY before.

  • 输入
  • There are several test cases.
    Each test case contains four parts, the first part contains 3 positive integers A, B, C, and A is the number which will come into the frontier. B is the number that will be sent by Nation Y, and C is the number that NationX has sent to NationY before.
    The second part contains A strings, the name list of that will come into the frontier.
    The second part contains B strings, the name list of that are sent by NationY.
    The second part contains C strings, the name list of the “dual_spy”.
    There will be a blank line after each test case.
    There won’t be any repetitive names in a single list, if repetitive names appear in two lists, they mean the same people.

  • 输出
  • Output the list that the commander should caught (in the appearance order of the lists B).if no one should be caught, then , you should output “No enemy spy”.

  • 样例输入
  • 8 4 3
    Zhao Qian Sun Li Zhou Wu Zheng Wang
    Zhao Qian Sun Li
    Zhao Zhou Zheng
    2 2 2
    Zhao Qian
    Zhao Qian
    Zhao Qian
    
  • 样例输出
  • Qian Sun Li
    No enemy spy
  • 提示
  • 来源
  • 辽宁省赛2010

题意是真的难懂(英语贼菜,看到长文章但是又不能从样例里面推出点东西的就直接放弃了),但是赛后翻译过来看,只要读懂题意,其实很简单

题意:

第一行是3个数字a,b,c,分别是下面三行字符串的个数,
第二行表示到达X国边境的a个人,
第三行表示Y国向外发放的间谍b人,
第四行的字符串表示X国向Y发放的间谍c人(dual_spy)
输出的是X国应该抓起来的来着Y国的间谍
即:在第二行的字符串中找到和第一行相同的字符串并且和第三行不同的字符串。(注意控制格式

参考代码:

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <string>
#include <vector>
#include <cmath>
#include <ctime>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
typedef long long LL;
const int N = 10005;
const int inf= 0x3f3f3f3f;
#define mm(a,b) memset(a,b,sizeof(a))
map<string,int>ans;
int main()
{
    int a,b,c;
    while(cin>>a>>b>>c)
    {
        string str[N];
        ans.clear();
        for(int i=0; i<a; i++)
        {
            string s;
            cin>>s;
            ans[s]=1;
        }
        for(int i=0; i<b; i++)
        {
            cin>>str[i];
            ans[str[i]]++;
        }
        for(int i=0; i<c; i++)
        {
            string s;
            cin>>s;
            ans[s]--;
        }
        bool flag=0;
        for(int i=0; i<b; i++)
        {
            if(ans[str[i]]==2)
            {
                if(flag)
                    cout<<" ";
                cout<<str[i];
                flag=1;
            }
        }
        if(!flag)
            cout<<"No enemy spy";
        cout<<endl;
    }
    return 0;
}

另外附上大佬char写的代码:https://blog.csdn.net/sdjzping/article/details/19234963