A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the

shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard

exactly once. He thinks that the most difficult part of the problem is determining the smallest number

of knight moves between two given squares and that, once you have accomplished this, finding the tour

would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the ”difficult” part.

Your job is to write a program that takes two squares a and b as input and then determines the

number of knight moves on a shortest route from a to b.

Input

The input file will contain one or more test cases. Each test case consists of one line containing two

squares separated by one space. A square is a string consisting of a letter ( a.. h) representing the columnand a digit 1..8)representing the row on the chessboard.

Output

For each test case, print one line saying ‘

To get from xx to yy takes n knight moves. ’.

Sample Input

e2 e4

a1 b2

b2 c3

a1 h8

a1 h7

h8 a1

b1 c3

f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.

To get from a1 to b2 takes 4 knight moves.

To get from b2 to c3 takes 2 knight moves.

To get from a1 to h8 takes 6 knight moves.

To get from a1 to h7 takes 5 knight moves.

To get from h8 to a1 takes 6 knight moves.

To get from b1 to c3 takes 1 knight moves.

To get from f6 to f6 takes 0 knight moves.

题意:

      国际象棋求两颗棋子之间的最小步数。

思路:

      广搜的模板。

代码:

#include<stdio.h>
#include<string.h>
char a[10],b[10];
int book[10][10];
struct data
{
	int x;
	int y;
	int step;
}q[110];
int bfs(int sx,int sy,int ex,int ey)
{
	int k,tx,ty,tail,head;
	int next[8][2]={1,2, 2,1, 2,-1, 1,-2, -1,-2, -2,-1, -2,1, -1,2};
	memset(book,0,sizeof(book));
	head=0;
	tail=0;
	q[tail].x=sx;
	q[tail].y=sy;
	q[tail].step=0;
	tail++;
	book[sx][sy]=1;
	while(head<tail)
	{
		if(q[head].x==ex&&q[head].y==ey)
			return q[head].step;
		for(k=0;k<8;k++)
		{
			tx=q[head].x+next[k][0];
			ty=q[head].y+next[k][1];
			if(tx>=1&&tx<=8&&ty>=1&&ty<=8&&book[tx][ty]==0)
			{
				q[tail].x=tx;
				q[tail].y=ty;
				q[tail].step=q[head].step+1;
				tail++;
				book[tx][ty]=1;
			}
		}
		head++;
	}
	return 0;
}
int main()
{
	int sx,sy,ex,ey,c;
	while(scanf("%s%s",a,b)!=EOF)
	{
		sx=a[0]-96;
		sy=a[1]-48;
		ex=b[0]-96;
		ey=b[1]-48;
		c=bfs(sx,sy,ex,ey);
		printf("To get from %s to %s takes %d knight moves.\n",a,b,c);
	}
	return 0;
}