Problem Description

“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。

 

Input

输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。
注意:询问之间无先后关系,都是针对当前状态的!

 

Output

每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。

 

Sample Input

3 4
1 2 3 4
0 0 0 0
4 3 2 1
4
1 1 3 4
1 1 2 4
1 1 3 3
2 1 2 4
3 4
0 1 4 3
0 2 4 1
0 0 0 0
2
1 1 2 4
1 3 2 3
0 0


Sample Output

YES
NO
NO
NO
NO
YES

 

#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
using namespace std;
int m[1005][1005],vis[1005][1005];
int s,n;
int x1,y1,x2,y2;
int dir[4][2]={{-1,0},{0,1},{1,0},{0,-1}};
struct nod
{
    int x,y;
    int t;
};
bool pd(int x,int y)
{
    if(x>0&&x<=s&&y>0&&y<=n&&m[x][y]==0&&vis[x][y]==0)
        return true;
    else
        return false;
}
int bfs()
{
    int a,b,c,d,e;
    nod beg,en;
    queue<nod>w;
    memset(vis,0,sizeof(vis));
    beg.x=x1;
    beg.y=y1;
    beg.t=-1;
    vis[x1][y1]=1;
    w.push(beg);
    while(!w.empty())
    {
        en=w.front();
        w.pop();
        if(en.t>2)
            continue;
        if(en.x==x2&&en.y==y2&&en.t<=2)
        {
            return 1;
        }
        for(a=0;a<4;a++)
        {
            beg.x=en.x+dir[a][0];
            beg.y=en.y+dir[a][1];
            beg.t=en.t+1;
            while(1)
            {
                if(!pd(beg.x,beg.y))
                    break;
                vis[beg.x][beg.y]=1;
                w.push(beg);
                beg.x=beg.x+dir[a][0];
                beg.y=beg.y+dir[a][1];
            }
        }
    }
    return 0;
}
int main()
{
    int a,b,c,d,e,f,g,h;
    while(cin>>s>>n)
    {
        if(s==0&&n==0)
            break;
        for(c=1;c<=s;c++)
        {
            for(d=1;d<=n;d++)
            {
                scanf("%d",&m[c][d]);
            }
        }
        scanf("%d",&e);
        while(e--)
        {
            scanf("%d %d %d %d",&x1,&y1,&x2,&y2);
            if(m[x1][y1]!=m[x2][y2])
                printf("NO\n");
            else if(m[x1][y1]==0||m[x2][y2]==0)
                printf("NO\n");
            else if(x1==x2&&y1==y2)
                printf("NO\n");
            else
            {
                a=m[x1][y1];
                m[x1][y1]=m[x2][y2]=0;
                if(bfs())
                    cout<<"YES"<<endl;
                else
                    cout<<"NO"<<endl;
                m[x1][y1]=m[x2][y2]=a;
            }
        }
    }

    return 0;
}