A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.

Query-1: “Every five minutes, retrieve the maximum temperature over
the past five minutes.” Query-2: “Return the average temperature
measured on each floor over the past 10 minutes.”

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency. For the Argus, we use the following instruction to register a query:

Register Q num Period Q num (0 < Qnum ≤ 3000) is query ID-number, and Period (0 < Period ≤ 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds. Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q num.

Input
The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of ‘#’. The second part is your task. This part contains only one line, which is one positive integer K (≤ 10000).
Output
You should output the Q num of the first K queries to return the results, one number per line.
Sample Input
Register 2004 200 Register 2005 300 # 5
Sample Output
2004 2005 2004 2004 2005

题目大意:
有n个触发器,他们的编号是num,触发时间的peiord;
给定一个数k,让你模拟k次触发器,输出它们的编号,编号输出规则period少的先输出,当period相同时,先输出num小的。

一个模拟题,用stl优先队列模拟维护,每次取队列里面累计时间最少的元素输出它的num,如果元素相同时,输出num小的。
代码:

#include<iostream>
#include<queue>
#include<string>
using namespace std;

struct item
{
	int time;//积累 
	int num;
	int periord;
	bool operator<(const item &a)const{//按照累积时间从小到大排序 
		if(time==a.time){
			return periord>a.periord;
		}	
		return time>a.time;	
	}
}; 
int main()
{
	priority_queue<item>t;
	string str;
	while(cin>>str){
		if(str[0]=='#')break;
		struct item pq;
		cin>>pq.num>>pq.periord;
		pq.time=pq.periord;
		t.push(pq);
	}
	int k;
	cin>>k;
	while(k--)
	{
		item q=t.top();
		cout<<q.num<<endl;
		t.pop();
		q.time+=q.periord;
		t.push(q);
	}
}

总结:熟悉了一个优先队列自定义比较函数;

bool operator<(const item &a)const{
		if(time==a.time){
			return periord>a.periord;
		}	
		return time>a.time;	
	}