Max Factor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13045    Accepted Submission(s): 4086


 

Problem Description

To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.

 

Input

* Line 1: A single integer, N

* Lines 2..N+1: The serial numbers to be tested, one per line

 

Output

* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.

 

Sample Input

4 36 38 40 42

 

Sample Output

38

代码:

#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define inf 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))

int a[20005];

void prime()
{
	for(int i=2;i<=20001;i++)
		a[i]=0;
	a[1]=1;//这道题里1算质数
	for(int i=2;i<=20001;i++)
	{
		if(a[i]==0)
		{
			for(int j=i;j<=20001;j+=i)    //保存j的最大质数因子
			{
				a[j]=i;
			}
		}
	}
}

int main()
{
	int t,n,i;
	prime();
	while(~scanf("%d",&t))      
	{
		int maxn=-1,s;
		while(t--)
		{
			cin>>n;
			if(maxn<a[n])
			{
				maxn=a[n];
				s=n;
			}
		}
		cout<<s<<endl;
	}
	return 0;
}