Description
Today we have a number sequence A includes n elements.
Nero thinks a number sequence A is good only if the sum of its elements with odd index equals to the sum of its elements with even index and this sequence is not a palindrome.
Palindrome means no matter we read the sequence from head to tail or from tail to head,we get the same sequence.
Two sequence A and B are consider different if the length of A is different from the length of B or there exists an index i that $A_{i}\neq B_{i}$.
Now,give you the sequence A,check out it’s good or not.
Input
The first line contains a single integer T,indicating the number of test cases.
Each test case begins with a line contains an integer n,the length of sequence A.
The next line follows n integers $A_{1},A_{2}, \ldots, A_{n}$.
[Technical Specification]
1 <= T <= 100
1 <= n <= 1000
0 <= $A_{i}$ <= 1000000
Output
For each case output one line,if the sequence is good ,output "Yes",otherwise output "No".
Sample Input
3
7
1 2 3 4 5 6 7
7
1 2 3 5 4 7 6
6
1 2 3 3 2 1
Sample Output
No
Yes
No
///本题就是让我们,统计给定序列奇数项的和是否为整个序列和的一半,并且这个序列为回文串,就输出Yes,否则为No,模拟就好。
//@zhangxiaoyu
//2015/8/12
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int a[1010];
int main()
{
int tt,n;
bool flag;
scanf("%d",&tt);
while(tt--)
{
int sum1=0,sum2=0;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
sum1+=a[i];
}
for(int i=0;i<n;i+=2)
sum2+=a[i];
flag=true;
for(int i=0,j=n-1;i<=j;i++,j--)
{
if(a[i]!=a[j])
{
flag=false;
break;
}
continue;
}
if(sum2*2==sum1&&(flag==false))
printf("Yes\n");
else
printf("No\n");
}
return 0;
}