When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion.
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced.

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000

分析:

利用几何关系可以求出l’与m的关系,但非常复杂,但有单调性,m↑l’↑,m↓l’↓,故在[0,l/2]二分m,根据m对应的l’与公式得出的真正的l’对比不断缩小m的范围。

#include<cstdio>
#include<iostream>
#include<cmath>
using namespace std;

double l,n;
double c,l_,l2;
double L,R,m;

int main()
{
//	freopen("input.in","r",stdin);
	while(cin>>l>>n>>c)
	{
		if(l<0&&n<0&&c<0)break;
		L=0;
		R=l/2;
		l_=(1+n*c)*l;
		while(R-L>1e-5)
		{
			m=(L+R)/2;
			double r=m/2+l*l/m/8;
			l2=2*r*asin(l/r/2);
			if(l2<l_)L=m;
			else R=m;
		}
		printf("%.3f\n",L);
	}
	return 0;
}