Now you are given one non-negative integer n in 10-base notation, it will only contain digits ('0'-'9'). You are allowed to choose 2 integers i and j, such that: i!=j, 1≤i<j≤|n|, here |n| means the length of n’s 10-base notation. Then we can swap n[i] and n[j].

For example, n=9012, we choose i=1, j=3, then we swap n[1] and n[3], then we get 1092, which is smaller than the original n.

Now you are allowed to operate at most M times, so what is the smallest number you can get after the operation(s)?

Please note that in this problem, leading zero is not allowed!

Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 2 integers n and M (0≤n<10^1000, 0≤M≤100) in a single line.

Output

For each test case, output the minimum number we can get after no more than M operations.

Sample Input

3
9012 0
9012 1
9012 2

Sample Output

9012
1092
1029

模拟:从左往右遍历当前数值,从右往左找最小值,找到之后如果小于当前数值,就交换,注意第一位不能和0交换

举个例子:9012:   

                 m=1, 当前数值9,从“012”里面从右往左找第一个最小值,(这里9是第一位,所以拿1和9交换);

     ——> 1092     

                 m=2,跳过0(因为0小于后面能找到的最小值),当前数值为1,后面只有2,交换1,2;

    ——>  1029

#include<iostream>
#include<string>
using namespace std;
int main(){
    int t,m;
    cin>>t;
    while(t--){
        string s;
        cin>>s>>m;
        int n=s.length();
        int tp=0;//计数
        int pos; //最小值位置
        for(int i=0;i<n;i++){
            if(tp>=m) break;
            int Min=100;   //找最小值用的
            for(int j=n-1;j>i;j--){
                 if(!i&&s[j]=='0'){  //第一位数字,并且后面找到了0
                     continue;       
                 }
                 if((s[j]-'0')<Min){ 
                     Min=s[j]-'0';//记录最小值和位置
                     pos=j;
                 }
            }
            if(s[i]>s[pos]){    //如果找到的值比当前位的值小才交换
                swap(s[i],s[pos]);  //这个很重要
                tp++;
            }
        }
        cout<<s<<endl;
    }
    return 0;
}