题干:

Do you know stack and queue? They're both important data structures. A stack is a "first in last out" (FILO) data structure and a queue is a "first in first out" (FIFO) one.

Here comes the problem: given the order of some integers (it is assumed that the stack and queue are both for integers) going into the structure and coming out of it, please guess what kind of data structure it could be - stack or queue?

Notice that here we assume that none of the integers are popped out before all the integers are pushed into the structure.

Input

There are multiple test cases. The first line of input contains an integer T (T <= 100), indicating the number of test cases. Then T test cases follow.

Each test case contains 3 lines: The first line of each test case contains only one integer N indicating the number of integers (1 <= N <= 100). The second line of each test case contains N integers separated by a space, which are given in the order of going into the structure (that is, the first one is the earliest going in). The third line of each test case also contains N integers separated by a space, whick are given in the order of coming out of the structure (the first one is the earliest coming out).

Output

For each test case, output your guess in a single line. If the structure can only be a stack, output "stack"; or if the structure can only be a queue, output "queue"; otherwise if the structure can be either a stack or a queue, output "both", or else otherwise output "neither".

 

Sample Input

4
3
1 2 3
3 2 1
3
1 2 3
1 2 3
3
1 2 1
1 2 1
3
1 2 3
2 3 1

Sample Output

stack
queue
both
neither

解题报告:

    题干很长但是题目很简单,按照要求模拟即可,注意情况要列全。

AC代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring> 
using namespace std;
int in[105];
int out[105];
int main()
{
	int T,n;
	
	cin >> T;
	int flag=1;
	while(T--){
		flag=1;
		memset(in,0,sizeof(in));
		memset(out,0,sizeof(out));
		
		cin >>n;
		for(int i=1;i<=n;i++){
			cin >> in[i];
		}
		for(int i=1;i<=n;i++){
			cin >> out[i];
		}
		for(int i=1;i<=n;i++){
			if(in[i]!=out[i]) {
				flag=0;
				break;	
			}
		}
		if(flag==1){
			reverse(in+1,in+n+1);
			for(int i=1;i<=n;i++){
				if(in[i]!=out[i]){
					flag=2;
					break;
				} 
			}
			if(flag==1) {
				printf("both\n");
				continue;
			}
			else{
				printf("queue\n");
				continue;
			}
		}
		else{
			reverse(in+1,in+n+1);
			for(int i=1;i<=n;i++){
				if(in[i]!=out[i]){
					flag=2;
					break;
				} 
			}
			if(flag==0) {
				printf("stack\n");
				continue;
			}
			else{
				printf("neither\n");
				continue;
			}
		}
		
	}
	
	return 0 ;
}