http://poj.org/problem?id=2184

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 
 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 

C++版本一

给出num(num<=100)头奶牛的S和F值(-1000<=S,F<=1000),要求在这几头奶牛中选出若干头,使得在其总S值TS和总F值TF均不为负的前提下,求最大的TS+TF值

可以把S当体积,F当价值做01背包。但是注意是S可为负,所以整体加100000,然后要注意DP顺序,S为负是要顺序,为正时逆序。

还有就是注意DP时的范围,凡是可能影响的都要包括。

/*
*@Author:   STZG
*@Language: C++
*/
//#include <bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<string>
#include<vector>
#include<bitset>
#include<queue>
#include<deque>
#include<stack>
#include<cmath>
#include<list>
#include<map>
#include<set>
//#define DEBUG

using namespace std;
typedef long long ll;
const int N=100+10;
const int M=2e5+10;
const double PI = acos(-1.0);
const double EXP = 1E-8;
const int INF = 0x3f3f3f3f;
int n,m;
int s[N],t[N],dp[M];
int main()
{
#ifdef DEBUG
	freopen("input.in", "r", stdin);
	//freopen("output.out", "w", stdout);
#endif
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%d%d",&s[i],&t[i]);
    }
    for(int i=0;i<=200000;i++){
        dp[i]=-INF;
    }
    dp[100000]=0;
    for(int i=1;i<=n;i++){
        if(s[i]<0&&t[i]<0)
            continue;
        if(s[i]>0)
            for(int j=200000;j>=s[i];j--){
                if(dp[j-s[i]]>-INF){
                    dp[j]=max(dp[j],dp[j-s[i]]+t[i]);
                }
            }
        else
            for(int j=s[i];j<=200000+s[i];j++){
                if(dp[j-s[i]]>-INF){
                    dp[j]=max(dp[j],dp[j-s[i]]+t[i]);
                }
            }

    }
    int ans=0;
    for(int i=100000;i<=200000;i++)
        if(dp[i]>=0)
            ans = max(ans,dp[i]+i-100000);
    cout<<ans<<endl;
    //cout << "Hello world!" << endl;
    return 0;
}

C++版本二

我们不如把两个因变量的其中一个当作自变量,求出这个因变量之后,其对应的自变量就是另一原问题的因变量了。
所以我们把聪明值看作是体积(自变量),把有趣值看作是因变量,因为自变量有负值,所以我们给每个自变量加上1000,方便作为DP数组的下标,这样只需要记录下当前体积用了多少个1000,最后再减掉就行了。
 

#include<iostream>
#include<cstdio>
#include<string>
#include<string.h>
#include<algorithm>
#define maxn 200010
#define inf 0x3f3f3f
using namespace std;
int NN = 1000;
int dp[maxn];
int cnt[maxn];
int v[105], w[105];
int main()
{
    int n;
    scanf("%d", &n);
    int sum = 0;
    for (int i = 1; i <= n; i++) 
    {
        scanf("%d%d", &v[i], &w[i]);
        if (v[i]<0 && w[i]<0) { i--; n--; continue; }
        v[i] += 1000;
        sum += v[i];
    }
    for (int i = 0; i <= sum; i++) dp[i] = -inf;
    dp[0] = 0;
    memset(cnt, 0, sizeof(cnt));
    for (int i = 1; i <= n; i++)
    {
        for (int j = sum; j >= v[i]; j--) 
        {
            if (dp[j - v[i]] + w[i] + j - (cnt[j - v[i]] + 1)*NN>dp[j] + j - cnt[j] * NN)
            {
                dp[j] = dp[j - v[i]] + w[i];//体积为j时候,可以获得的最大价值
                cnt[j] = cnt[j - v[i]] + 1;//体积为j的时候,用了多少个多少个1000
            }
        }
    }
    int ans = 0;
    for (int i = 1000; i <= sum; i++) 
    {
        if (dp[i] >= 0 && i - cnt[i] * 1000 >= 0)
            ans = max(ans, dp[i] + i - cnt[i] * 1000);
    }
    cout << ans << endl;
}