Problem Description
Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I’ve built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height. Then you would have a real wall.”, she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

Input
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1≤n≤50 and 1≤hi≤100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

Output
For each set, print the minimum number of bricks that have to be moved in order to make all the stacks the same height.
Output a blank line between each set.

Sample Input
6
5 2 4 1 7 5
0

Sample Output
5

解题步骤:
1.输入:很简单常规操作
2.输出:这里每两个输出结果之间有一个空行,最后一个结果没有空行,常规操作。
3.思路:
他是求最小路径,事实上只要我们每次给他排序一下,然后最大-1最小+1就完事了。
在排序前要判一下是否所有元素相等。当所有元素相等就可以退出了,事实上这个题目不够严谨存在着有可能你把所有的序列排序好了但是他并不满足要求,例如1 2 3 4 5 6,大家可以试一下,oj后台没有把这种情况放进来,所以可以放心ac了。
以下个人ac代码(c++):

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<algorithm>
#include<set>
#define max 1000
using namespace std;
int a[max];
bool iswall(int a[],int n)
{
	set<int>st;
	for(int i=0;i<n;i++)
	{
		st.insert(a[i]);
	}
	return st.size()==1;
}
bool cmp(int a,int b)
{
	return a>b;
}
int main()
{
	int n;
	int flag=0;
	while(cin>>n&&n)
	{
		if(flag)cout<<endl;
		flag=1;
		memset(a,0,sizeof(a));
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
		}
		int count=0;
	//	 cout<<iswall(a,n)<<endl;
		while(!iswall(a,n))
		{
			sort(a,a+n,cmp);
			//for(int i=0;i<n;i++)
			//cout<<a[i]<<"   ";
			a[0]--;
			a[n-1]++;
			count++;
		}
		cout<<count<<endl;
	}
}