题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1022
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

Sample Input

3 123 321
3 123 312

Sample Output

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

Hint

Hint For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".

Problem solving report:

Description: 给你火车的进站顺序和出站顺序,判断实际情况有没有这种顺序。
Problem solving: 直接判断就行了,判断栈顶的元素是不是待出栈的元素,是就出栈,不是就再进来元素,继续判断,最后再判断元素是否都已出栈。注意记录一下进栈出栈的顺序,1代表进栈,0代表出栈。

Accepted Code:

#include <bits/stdc++.h>
using namespace std;
const int MAXN = 10005;
int turn[MAXN];
char from[MAXN], to[MAXN];
typedef struct ListPtr {
    char data;
    ListPtr *prior;
}*lists;
int len;
lists head, tail;
void Alloc(lists &p) {
    p = (ListPtr *)malloc(sizeof(ListPtr));
    p -> prior = NULL;
}
void link() {
    len = 0;
    Alloc(head);
    tail = head;
}
void push(char e) {//入栈
    lists p;
    Alloc(p);
    p -> data = e;
    p -> prior = tail;
    tail = p;
    len++;
}
void pop() {//出栈
    len--;
    lists p = tail;
    tail = tail -> prior;
    free(p);
}
int top() {//访问栈顶元素
    return tail -> data;
}
int main() {
    int n;
    while (~scanf("%d%s%s", &n, from, to)) {
        link();
        int tmp = 0, p = 0;
        for (int i = 0; i < n; i++) {
            push(from[i]);
            turn[p++] = 1;//1代表入栈
            while (len && top() == to[tmp]) {
                tmp++;
                pop();
                turn[p++] = 0;//0代表出栈
            }
        }
        if (tmp != n)
            printf("No.\n");
        else {
            printf("Yes.\n");
            for (int i = 0; i < p; i++) {
                if (turn[i])
                    printf("in\n");
                else printf("out\n");
            }
        }
        printf("FINISH\n");
    }
    return 0;
}