/*
Argus
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 11829 Accepted: 5782
Description


A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following. 
Query-1: "Every five minutes, retrieve the maximum temperature over the past five minutes." 
Query-2: "Return the average temperature measured on each floor over the past 10 minutes."


We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency. 


For the Argus, we use the following instruction to register a query: 
Register Q_num Period


Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds. 


Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num. 
Input


The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#". 


The second part is your task. This part contains only one line, which is one positive integer K (<= 10000). 
Output


You should output the Q_num of the first K queries to return the results, one number per line.
Sample Input


Register 2004 200
Register 2005 300
#
5
Sample Output


2004
2005
2004
2004
2005*/


#include<iostream>
#include<string>
using namespace std;
struct Node{
int Now; //出堆的时间 
int Q; //Q_num 
int P; //Period
}; 
Node node[3001];
int k;
//向下调整堆----将节点数为 m 的 H 堆数组的第 s 个节点向下调整 
void down(Node H[],int s,int m)  
{
Node rc=H[s];
int j;
for(j=s*2;j<=m;j*=2){
if(j<m) //不是最后一个节点 
{
if(H[j].Now>H[j+1].Now) //先对两个儿子节点进行比较 
{
j++;
}else{
//当两个任务在同一时间执行时,先输出id小的 
if((H[j].Now==H[j+1].Now)&&(H[j].Q>H[j+1].Q))
++j;
}
}
if(rc.Now<H[j].Now||(rc.Now==H[j].Now&&rc.Q<H[j].Q))
break;
H[s]=H[j];
s=j;
}
H[s]=rc;
}
void MakeMinHeap(Node H[],int length) //建立一个最小堆 
{
for(int i=length/2/*叶节点不用调整*/;i>0;--i){
down(H,i,length);
}



int main()
{
string str;
int i=1;
cin>>str;
while(str.compare("#")!=0){
cin>>node[i].Q>>node[i].P;
node[i].Now=node[i].P;
i++;
cin>>str;
}
int len=i-1;
cin>>k;
MakeMinHeap(node,len);
for(i=1;i<=k;++i){
cout<<node[1].Q<<endl;
node[1].Now+=node[1].P;
down(node,1,len);
}
return 0;