题目

本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:
输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。
输出格式:
对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y。
输入样例 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例 2:
2
aaa -9999
输出样例 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

思路:首先在判断是不是合法数字的时候想到了 isdigit() ,发现这个只能判断是不是整数,所以用排除法将不符合的都剔除。

N = int(input())
lst = input().split()
total, num = 0, 0
for m in lst:
    if m.isalpha() or m.count('.') > 1 or m == '-':
        print('ERROR: {} is not a legal number'.format(m))
        continue
    # 使用float转化可以使整数也带上小数点
    a = str(float(m)).split('.')
    if float(m) < -1000 or float(m) > 1000 or len(a[1]) > 2:
        print('ERROR: {} is not a legal number'.format(m))
        continue
    total += float(m)
    num += 1
if num == 0:
    print('The average of 0 numbers is Undefined')
elif num == 1:
	# 需要注意这里的number没有加s
    print('The average of 1 number is {:.2f}'.format(total / num))
else:
    print('The average of {} numbers is {:.2f}'.format(num, total / num))