Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.
 



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.
 



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

 

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

 

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

 

Sample Input

3

4

10 20

30 40

50 60

70 80

2

1 3

2 200

3

10 100

20 80

30 50

Sample Output

10

20

30

题意:

      有四百个房间在走廊的两边,从房间s把桌子挪到房间 t,同一段走廊只能放下一张桌子,一张桌子从一个房间移动到另一个房间需要10分钟,不是同一段走廊的话可以同时移动,求移动所有桌子所需要的最短时间。

思路:

      走廊两边的房间看成一个整体(1 , 2)为走廊1,(3 ,4)为走廊2....走廊k每使用一次标记一下,最后求最大标记数*10就是所需要的最短时间。

     一开始想着把区间排序看相邻区间有没有交叉部分,但是忽略了一些情况,比如(3, 5)与(6, 8)这种情况也就是前一个的后一位与后一个的前一位相邻的情况。

代码:

#include<stdio.h>
#include<string.h>
int main()
{
	int t,n,i,j,a,b,a1,b1,max,h;
	int book[1010];
	scanf("%d",&t);
	while(t--)
	{
		memset(book,0,sizeof(book));
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&a,&b);
			if(a>b)
			{
				h=a;a=b;b=h;
			}
			a1=(a+1)/2;
			b1=(b+1)/2;
			for(j=a1;j<=b1;j++)
			{
				book[j]++;
			}
		}
		max=0;
		for(i=1;i<=220;i++)
		{
			if(book[i]>max)
				max=book[i];
		}
		printf("%d\n",max*10);
	}
	return 0;
}