Problem Description

有一只经过训练的蜜蜂只能爬向右侧相邻的蜂房,不能反向爬行。请编程计算蜜蜂从蜂房a爬到蜂房b的可能路线数。
其中,蜂房的结构如下所示。

 

 

Input

输入数据的第一行是一个整数N,表示测试实例的个数,然后是N 行数据,每行包含两个整数a和b(0<a<b<50)。

 

 

Output

对于每个测试实例,请输出蜜蜂从蜂房a爬到蜂房b的可能路线数,每个实例的输出占一行。

 

 

Sample Input


 

2 1 2 3 6

 

 

Sample Output


 

1 3

#include<iostream>
using namespace std; 
typedef long long ll;
ll a[55];
void table(){
	a[0]=1;
	a[1]=1;          //[]里面存的是间距 :a[1],两个方块间隔1 
	for(int i=2;i<=50;i++){
		a[i]=a[i-1]+a[i-2]; //斐波那契数列 
	}                       //想要到达每一块,必须从他前两块过来 
	
}
int main(){
	int t;
	cin>>t;
	table();
	while(t--){
		ll s,e;
		cin>>s>>e;
		cout<<a[e-s]<<endl;
	} 
	return 0;
}