Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个 区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子
 1  2  3  4 5 
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

dp加DFS。

//Asimple
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cctype>
#include <cstdlib>
#include <stack>
#include <cmath>
#include <string>
#include <queue>
#define INF 100000
using namespace std;
const int maxn = 105;
typedef long long ll ;
int n, m;
int a[maxn][maxn];
int dp[maxn][maxn];
int dx[]={0,0,1,-1}, dy[]={1,-1,0,0};

bool worng(int x, int y){//边界 
    return x < 0 || x >= n || y < 0 || y >= m ; 
}

int getdp(int i, int j){
    if( dp[i][j] > 1 ) return dp[i][j];
    int Max = 1;
    for(int k=0; k<4; k++){
        if( !worng(i+dx[k],j+dy[k]) && a[i][j] > a[i+dx[k]][j+dy[k]] ){
            int h = getdp(i+dx[k],j+dy[k])+1;
            if( h > Max ){
                Max = h ;
            }
        }
    }
    return Max;
}

int main(){
    int sum;
    cin >> n >> m;
    for(int i=0; i<n; i++){
        for(int j=0; j<m; j++){
            cin >> a[i][j];
            dp[i][j] = 1 ;
        }
    }
    int ans = 1 ;
    for(int i=0; i<n; i++){
        for(int j=0; j<m; j++){
            dp[i][j] = getdp(i,j);
            if( ans < dp[i][j] ) ans = dp[i][j] ;
        }
    }
    cout << ans << endl ;
    return 0;
}